PDF User Manual

  1. Home
  2. Manuals
  3. 3rdTech DeltaSphere-3000 Quick Manuals

3rdTech DeltaSphere-3000 Quick Manuals

SceneVision-3D

Made by: 3rdTech
Type: Quick Guides
Category: Camera Accessories
Pages: 9
Size: 0.12 MB

 

Download PDF User Manual


Related Product Video

 

Full Text Searchable PDF User Manual



background image

 

 
 

DeltaSphere-3000 3D Scene Digitizer 

and SceneVision-3D 

Quick guides

 

3rdTech, Inc. 

3rdTech, Inc. 

 

 

Copyright © 2005 3rdTech, Inc. 

9/23/2005

 


background image

DeltaSphere-3000 3D Scene Digitizer 

 

9/23/05 

Setting Up the DeltaSphere-3000 

1.  Set up the tripod in a central location for a ‘reference’ scan; or in a location that needs to be scanned first - before the scene changes.  

o

 

Make it relatively level. If using the dolly, place it on the dolly and lock the legs in place.  

o

 

Choose a height appropriate for the scan. Lock the legs. 

2.  Attach the quick release base to the tripod. Attach the quick release plate to the DeltaSphere. Unlock the quick release base. Place and lock the 

DeltaSphere onto the tripod 

3.  Place the power supply on the tripod, high on a leg so there’s enough slack cable for the DeltaSphere to rotate. Connect it to the DeltaSphere 

and to the power strip. Connect the power strip to power.  

o

 

Turn on the DeltaSphere (with the switch and the key) to allow it to warm up for 10 minutes. 

4.  While it’s warming up, if you’re going to scan with color, attach the camera mount with its thumbscrew. 

5.  Rotate the camera mount so it is facing down in order to free up the camera mounting screw and hole.  

6.  Check that the camera is on manual and F22 and the focus has the middle of the infinity symbol set on 4. Attach the camera to the camera 

mount. Recheck the focus. 

7.  While it’s still warming up, set up the laptop stand – low enough so that the screen won’t block the DeltaSphere from turning. (Choose a 

convenient leg that’s easy to reach.) 

8.  Place the laptop on the laptop stand. Attach 4 cables. 

o

 

Attach the laptop power to a leg of the tripod. Connect it to the laptop and to the power strip. Use a tie wrap to collect any 
excess cable. No slack is require. 

o

 

Attach the crossover Ethernet cable to the laptop and to the DeltaSphere. 

o

 

Attach the camera’s power cable to the camera and to the power strip. 

o

 

Attach the 1394 (Firewire) cable from the camera to the laptop. (You may need to add the 1394 card to the laptop first.) 

9.  Gather the four cables (DeltaSphere power, Ethernet, Camera Power and 1394/Firewire), starting near where the power and Ethernet cables 

attach to the DeltaSphere, using a tie wrap. Continue down the cables, gathering the four cables together in several locations, ending near the 
power supply for the DeltaSphere, so they are neat and have enough slack to turn easily. 

o

 

Gather any excess cable with tie wraps to keep it from dragging or snagging. 

10.  Turn on the laptop. Once it is running and you’re logged in, run SceneVision-3D. 

11.  Select the Scan tab. With the correct IP address set (should be the default) Connect to the DeltaSphere. If the button turns yellow then green 

you’re connected.  

o

 

If there’s a problem, check that the IP address on the DeltaSphere case is the address you’re using. Also check the Ethernet 
cable at both ends. Then try connecting again. 

12.  Turn on the camera. Try connecting to it. It should connect quickly. If not, check the 1394 card and check that the cable is attached at both 

ends. Turn the camera off and on and try connecting again. 

13.  If 10 minutes are up, you’re ready to scan. If not, it’s a good time to plan the different locations for scanning. 

 

 

 


background image

DeltaSphere-3000 3D Scene Digitizer 

 

9/23/05 

II  Range Scanning with the DeltaSphere-3000 

Your system is set up and warmed up as described in quick guide I, and SceneVision is running and connected to the 
DeltaSphere-3000. 

1.  Raise the geared column on tripod 8 in. (20.3cm) using the 8” measuring rod or some other measurement. 

2.  Lock the tripod’s geared column screw.  If you’re using the dolly, lower  it. 

3.  Check that quick-release base is tightly screwed to tripod 

4.  If this is the first scan of a scene, select New Scene from the File menu. Type a name for the scene. All the scans from this scene will be 

included in this name.  

5.  Specify the horizontal field of view.  

o

 

If you are doing a 360

° scan, type -182  and +182 in the min and max boxes. -4 to 360 is okay as well – but make sure you 

have enough slack in the cables. 

o

 

If you’re not doing a full scan, use the manual pan controls to aim the system. Move it (usually with reverse buttons) to the 
starting point and select Set Min. Then move it (forward) to the ending point and select Set Max

Options 

• 

Select Make Zero at the starting point and then select Set Min. This will make the starting point 0. 

• 

If you want 0 to be a particular direction (e.g. north), use the manual pan control to aim the unit until it is facing north and select 
Make Zero. Then set the Horiz. FOV  as in step 5. 

• 

You can also simply type numbers into the Horiz. FOV boxes if you want. 

Note: If you can’t rotate back to the starting point because it’s farther than -185 (the limit), rotate it until it stops. 
Then Make Zero, then rotate it some more. 

6.  Set the vertical field of view. -55 to 75 is typical to cover an entire scene. Outdoors you may not need to go that high. 

7.  Set the speed in revolutions per second. 8 is the most common setting.. 

8.  Set resolution in sample/deg. 13.333 is the most common setting.  

Options 

• 

Use 15 if you want especially high resolution for detailed objects or for very long range scans. Use a lower number if all you’re 
trying to get is a simple room model or if you want a quick scan of the area. Set resolution to 5 and then set the speed to 16 to do a 
scan in under 2 minutes. 

9.  Set the max range. This is the maximum distance you will record in the scene. Choose a number that is definitely farther than you want to 

scan. 

10.  Clear the area and wear protective eyewear. 

11.  Select Start under the word Scan at the left of the window. You will be asked to name the scan. Name it something useful, e.g. westbed or 

kitchdoor. It will begin to scan. 

Note: The system rotates clockwise to the starting point and then scans in a counter-clockwise direction. Keep people 
out of the way of where it is scanning – but it’s not a disaster if someone walks through. 

12.  Save the scene by hitting the save button. The files are already written to the disk. 

o

 

When finished, don’t move anything until you capture color. Go to Capturing Color. 

Strategic Tips  

o

 

Do a ‘reference’, 360

° scan, for each individual room. It will help you align any smaller scans you do in the room. 

o

 

Do smaller scans for the backs of surfaces or for close-ups of key parts of a scene, but make sure you have enough overlap 
with other scans or with the reference scan to align them. You need more than a part of one wall to do good alignment – 
floors, ceiling, and corners help. 

o

 

If you need to connect 2 rooms, do a large scan with the tripod either in the doorway or very near the doorway. This will 
give you enough surfaces from the two rooms to align them. If the scanner is far from the doorway you’ll only get a small 
view of the adjacent room and it may not be enough for alignment. 

o

 

Set the tripod high enough for furniture surfaces or low enough to see beneath tables. This might require multiple scans 
from the same tripod location but with different heights. 

o

 

Scan key elements such as faces or artwork or blood spatter, facing them – not from a very oblique angle. 

o

 

Check your data. Do a quick ‘3D popup’ after a scan to make sure you got the data you needed. It only takes a minute. 
Select the range file window and hit the 3D Popup button. 

 


background image

DeltaSphere-3000 3D Scene Digitizer 

 

9/23/05 

III  Capturing Color with the DeltaSphere-3000 

Your system is set up, you’ve created a ‘scene’, and you’ve scanned for range from a particular location. Do not move the 
tripod between range and image scans. Do not move objects in the scene. 

1.  Lower the geared column on the tripod 8”. 

2.  Lock the tripod’s geared column screw and check that quick-release base is tightly screwed to tripod 

3.  Aim the camera downward, level, or upward.  

o

 

For many scans you’ll want to capture 2 sets of photos, one with the camera facing down and the other with it facing up, 
which covers the entire laser scan. In some cases you may only need to take a set of pictures at the middle, or level, setting. 

4.  Check the camera’s focus so that the infinity symbol is centered on the 4. 

5.  If you’re not connected to the camera, select the photo Connect button. If it doesn’t connect, check the 1394 cable and card, turn the camera 

off and on, and try it again.  

6.  Use the pan controls to rotate the DeltaSphere so that it is pointing where scanned. 

7.  Set the overlap to 20%. 

8.  Take a preview shot. Select Settings to open camera settings window.  

o

 

Adjust white balance. (Do not use Auto.) Adjust shutter speed. Preview. 

o

 

Repeat until you’re happy with the results.  

o

 

If it’s very dark you may need to increase the ISO, though this will increase the ‘noise’ in the photos. 

9.  Set the image compression and resolution. We recommend the 6 Mpixel (3024x2016,) and ‘Fine JPEG’ – the defaults. 

10.  Select the Auto Acq. tab and select Start underneath it. This will open a new window.  

o

 

Choose a name for the photos. (Typically this the same name as the laser scan, but change as needed.) 

o

 

Choose Hi, Mid or Low to correspond to the angle of the camera in the bracket. (This will be added to the photos’ names.) 

o

 

Set bracketing off or on and amount. We recommend always bracketing and using 1.0 (1 full f stop higher and lower). This 
will take 3 photos at each location. 

11.  Clear the area and select Start. Do not let people walk through the photos. The camera moves slowly to each position. 

12.  Change the camera position (hi, mid, or low) if desired (without moving the tripod).  

o

 

Repeat the preview and adjust the shutter speed if necessary.  

13.  Repeat steps 10 and 11. 

14.  Save the scene. Move the tripod to its next location. 

Close-up Photos 

• 

Take close up photos of key elements of a scene with the calibrated camera. These are used for high-resolution insets and photo 
hotspots. You can do this at any time – at the beginning, after 1 scan, or at the end. 

o

 

If doing it at the end, try this. Remove the camera from the DeltaSphere, remove the camera mount from the DeltaSphere, 
put the DeltaSphere away, place the camera directly on the tripod – preferably with a ‘pan/tilt’ head. Reconnect it to the 
laptop. Now it is easy to move the tripod and use the Manual Acquire controls. 

o

 

Do a preview and adjust the settings as you did above. 

Note: REMEMBER TO ADJUST THE WHITE BALANCE ON THE CAMERA BODY. Select the function button 
on the back of the camera. Then push the WB (white balance) button until you get the setting you want. It will often 
be the same setting you used for auto acquire. 

o

 

Choose Man Acq. You’ll be prompted for a file name and a directory. Use the default name or choose your own. The 
program will number the photos consecutively. 

o

 

Take a photo by selecting Take Pict or by pushing the shutter release.  

• 

You can also hold the camera by hand, but keep it cabled to the laptop, and use the Manual Acquire controls. 

• 

Alternatively, use the camera without the laptop. For this you will need a memory card. Remember to adjust the settings on the 
camera. Later, transfer the images to your computer and insert them into the scene.  

• 

Take lots of pictures; disk space is cheap. 

 


background image

DeltaSphere-3000 3D Scene Digitizer 

 

9/23/05 

IV  Range Alignment with SceneVision-3D 

You have SceneVision running, a scene open with multiple scans from different tripod locations, and are ready to do range 
alignment. Make the window large. 

1.  Select the Range Align tab. Then select the 1:New button.  

2.  Choose a file to base the alignment on. If no files are aligned, choose a reference or large scan. Otherwise, choose an aligned file that overlaps 

the file you want to align. 

3.  Choose a file to align. It must be a file that overlaps the previous selection. Windows for both files will open. 

4.  Go the Window menu and choose Tile Vertically. (Not required, but makes it easier to work.) 

5.  Your goal is to select 4 to 6 pairs of correspondence points. The Create Correspondence Point button is already selected. 

o

 

Zoom out to identify locations where you can find correspondence points. Zoom in to make the selection. 

o

 

Select a point in one window (it doesn’t matter which one) by holding Ctrl and picking with the mouse. Then select the 
corresponding point in the other window.  

o

 

Repeat 4 to 6 times. 

Note: The program uses the points as starting points only, so they should be good but need not be perfect. 

6.  Select the 2:Calc button. It will calculate the alignment. Errors below 0.3” are very good and below 0.5” are desirable.  

7.  Select 3:Apply. This aligns the file and a ruler appears next to the filename in the scene tree. 

8.  To do a quick check of the alignment, select the Show button. This will create a temporary 3D model of the two files. 

o

 

Look at the overlapping walls and edges of objects. Make sure they are ‘very’ close.  

9.  If it looks good you’re done. Save the scene with the save button and it will save all the correspondence points and the alignment.  

10.  If you’re not satisfied you can move any of the current points and/or add additional point pairs. 

Note: Make sure both points of a pair are on the same surface – not one on a surface in front and the other on a 
surface behind.  

o

 

To move a point, select the arrow cursor, hold Ctrl, and drag the point to a new location.  

o

 

To add a point, select the Create Correspondence Point button and then repeat step 5 above. 

Note: Try adding points on a different surface.  

11.  After adding or moving points repeat steps 6 - 9. 

Tactical Tips 

• 

The key to good alignment is good scanning! Make sure you provide plenty of overlap when scanning. Scanning an extra 90

° takes 

only a couple of extra minutes – but can make a big difference when doing alignment. (And you don’t need to include the extra 
data in your model.) 

• 

When choosing points to align, avoid the outside edges of objects, like furniture. It’s difficult to see if those points are on the object 
or on the background. Instead, choose ‘interior’ points or corners that are visible but are not on the edge. 

• 

Choose points that are not all in the same plane – from different walls, the floor and ceiling, and object surfaces – whenever 
possible. 

• 

The order you do alignment doesn’t matter. Also, alignment between and two overlapping files will work. For example, you can 
align Scan A to B, A to C, C to D and D to E and everything will be aligned. There just needs to be a link. 

• 

Sharing Alignment: Sometimes 2 files should have the same alignment. For example, fileA.rtpi might be aligned, and 
fileA_color.rtpi – the same file with color - might not be aligned. You can fix this easily – without redoing the alignment. 

o

 

Insert the color file into the scene if it is not already there. 

o

 

Select both files in the scene tree (one aligned and one not aligned). 

o

 

Select  Align->Share Alignment with from the Edit menu. 

o

 

You can also remove alignment from a file with Align->Clear Alignment in the Edit menu 

 


background image

DeltaSphere-3000 3D Scene Digitizer 

 

9/23/05 

V  Color Alignment with SceneVision-3D 

You have a range file and associated color photos acquired with the calibrated camera. SceneVision is running with the scene 
loaded. Make the window large. 

Note: You can only align color to an aligned range file. Do range alignment first. (Work-around below.) 

1.  Open the range file by double-clicking. Next choose Save File As in the File menu and give it a new name with the word ‘color’ in it.  e.g. if 

the file is kitchenref.rtpi we recommend kitchenref_color.rtpi. This creates a copy of the range file. 

2.  Take a look at the photos for the range file you want to color to decide which you want to use.  

o

 

Use Windows Explorer and look at them as thumbnails, or open up a few of them in SceneVision-3D by double-clicking on 
their names in the scene tree. The number in the name is the photo’s azimuth heading. 

3.  Select the Color Align tab.  Select 1:New. Choose the range file you want to color (the file created in step 1). 

4.  Choose the photo you want to align. ( It doesn’t matter where in the scan you begin.) Windows for both files will open. 

5.  Go the Window menu and choose Tile Vertically. (Not required, but makes it easier to work.) 

6.  Your goal is to select 5 to 8 (or more) pairs of correspondence points. The Create Correspondence Point button is already selected. 

o

 

Zoom out to identify locations where you can find correspondence points. Zoom in to make the selection. 

o

 

Select a point in one window (it doesn’t matter which one) by holding Ctrl and picking with the mouse. Then select the 
corresponding point in the other window. Select with precision. 

o

 

Repeat 5 to 8 times. 

Note: Choose points well. The program uses your points and does not improve on them as in range alignment.  

Note: Spread the points out around all parts of the image as much as possible. This is important! 

7.  Select the 2:Calc button. It will calculate the alignment. Errors below 4 pixels are very good and below 8 are desirable. Often errors above this 

are acceptable.  

8.  Select 3:Apply. The photo is now aligned (though not yet added to the range file.) 

o

 

Look at the pairs of points. .If they are not near each other, you can try moving them, then steps 7 and 8 again. 

9.  Select 4:Color. Look at the resulting color file – especially at edges near the edge of the image to see if they are aligned well. 

10.  If they are, hit the save button and, when asked whether to save the file, say yes.  

11.  If you are not satisfied with the alignment, do the following: 

o

 

Add or move points in the areas where there are misalignments 

o

 

Select Revert. The range file reverts to the last saved version – removing the most recent photo added. 

o

 

Then  2:Calc, 3:Apply, 4:Color.  

o

 

If satisfied, save. If not, repeat these 3 bullets. Then save. 

12.  For the next photo, select 1:New. Choose the same color range file and a new photo – usually one adjacent to the one just aligned. Repeat 

from step 5. A 360

° scan usually requires 9 high and 9 low photos. 

Tactical Tips 

• 

If you need to move a point once created, select the arrow cursor, hold Ctrl, and drag the point to a new location or move it with the 
arrow keys. You then need to reselect the Create Correspondence Point button to go back to picking. 

• 

Pick your photos consistently (e.g. all dk or all lt) so the color matches throughout. Maybe compare to other scans. 

• 

If you want to color a range file that hasn’t been aligned – perhaps you’re coloring and someone else is doing the range alignment – 
there is a solution 

o

 

Create a new, temporary scene. Insert the directory with the scan you want to color and all its photos. 

o

 

Because there is only 1 range file, it is considered ‘aligned’ and you can color it as above. 

o

 

When done, the resulting *_color.rtpi file can be inserted into the original scene. If the original range file has been aligned, 
you can ‘share alignment’ of this new file with the original range file – or you can align it. 

• 

If there is a part of the photograph you wish to ‘mask out’ – because you have better color from another photo, read the manual on 
‘masking’ in the color alignment chapter. 

• 

If you are not going to use part of a scan in your model, perhaps because you have better data from another scan, then you do not 
need to color that part of the scan. The uncolored part can be edited out in model building or model editing. 

 


background image

DeltaSphere-3000 3D Scene Digitizer 

 

9/23/05 

VI  Model Building with SceneVision-3D 

You’ve aligned all your range files, aligned all your color, and the color range files are aligned as a result. You will only use 
the color range files for this process. SceneVision is running and the scene is loaded on a fast PC with lots of memory. 

Note: The computer (not you) will be busy and unavailable for 1 or more hours. 

Note: This guide describes how to build high quality, ‘simplified’ models. Building quick models is described below.  

Note: You can follow these same steps with the original range files to build grey scale models. 

First, create simplified models of each individual scan. 

1.  In the scene tree, in the Range Data folder, select every color range file you might want to include in the model. Use Ctrl to make multiple 

selections. 

2.  Select Create Simplified Model from the Edit menu. A window will appear.  

3.  Select a size. Small will produce files with the smallest number of triangles. In most cases these will be very satisfactory – and easier to work 

with. Select Ok. 

4.  Next, name the output model file for each scan, one at a time. (Use the default in most cases, or choose another name.) 

o

 

When you’ve named them all the processing will begin. Go home. Full scans can take 45 minutes each – or more. 

o

 

When you return, your simplified, individual model files will be ready. You’ll find them in the scene tree in the Model Data 
folder – named, by default,  filename_reduced.wrl, each in its own scan folder. Double-click on any of them to view them 
individually. 

Next, combine the simplified models. 

5.  To combine them into a single model, select each of these files (or just the ones you want to combine) in the scene tree, and select Create 

Model from Selected Data in the Edit menu. You’ll be asked to name the new model. This will produce a model combining all of the files 
selected.  

o

 

If you want to keep this ‘merged’ file you need to save it with Save File or Save File As in the File menu. 

o

 

The resulting file will have a lot of overlapping areas. The quick guide on Model Editing discusses how to reduce the 
overlap.  

6.  You can also build up a model one file at a time.  

o

 

Select two models and then Create Model from Selected Data. Save the resulting model.  

o

 

Select this resulting model and a third model. Select Add Selected Data to Model. You’ll be asked to choose a ‘base file to 
merge other data into’. Choose the merged model. It will then add the third model to the merge. Save this. Add additional 
models as needed. 

Tactical Tips 

• 

You can add selected regions from a range (rtpi) file to any model. (The addition will not be simplified.) Select a region in a range 
file. Then, in the scene tree, select the range file and the model you want to add it to. Finally, select Add Selected Data to Model in 
the Edit menu. 

• 

Sometimes you know that you only want to include a part of a scan, instead of the whole scan, in a model. You can save time by 
only coloring the part you want to use. In addition, you can reduce the model simplification time above by telling the program only 
to simplify the part you want to use. To do this: 

o

 

In step 1 above, open the file you only want part of. Use the Select Region button to select the part you want to include. 

o

 

When you get to step 3 above, choose Selected Data Only and only the highlighted region will be included in the simplified 
model. 

• 

You can build models quickly and easily by skipping the Create Simplified Model function. Use the two functions Create Model 
from Selected Data 
and Add Selected Data to Model. Choose a range (rtpi) file – or select a region of a file – and create a model. 
Then add range files or regions of range files to that model. 

o

 

Each time you do this, the function uses the Preferences setting Target Number of Triangles per Model. It ‘decimates’ the 
data uniformly (horizontally and vertically) to reduce the number of triangles produced. 

o

 

These models will be rougher than the simplified models because of this uniform decimation. 

• 

You can also select a range file, or part of a range file, and select the Create 3D Popup from Region button to produce quick 
models. 

 


background image

DeltaSphere-3000 3D Scene Digitizer 

 

9/23/05 

VII  Model Editing with SceneVision-3D 

You’ve created a model as described in the Quick Guide to Model Creation. Editing can be done on a complete model from 
all scans or from a partial model from some scans. SceneVision is running and the scene is loaded. 

Note: Model edits do not ‘carry over’ to any other data files or models. Only edit models you care about. 

Note: There are 2 basic goals for model editing in SceneVision: 1) Deleting bad or extraneous data, and 2) Where 
two scans overlap, deleting the contribution from one of the scans. 

1.  Open the model by double clicking on the model filename in the scene tree. 

2.  Select Edit Model from the Edit menu. The Model Editor window will appear. (The next bullets are to see how it works.) 

o

 

It shows all of the ‘texture maps’ that make up your model. Each texture map is the color for a section of the model. The left 
part of the name is the range file it came from. Usually each range file has several texture maps. 

o

 

Select one of the texture maps in the Model Editor window and then Show Only. It shows the part of the model associated 
with that texture map. Now pick Show All. Then pick Hide. It hides just the part associated with that texture map. 

o

 

For practice, try selecting all the textures associated with a scan and do Show Only or Hide. In this way you can display the 
parts of a model that come just from a particular scan. 

First, delete bad or extraneous data. 

3.  Display the part of a model from one scan at a time by selecting all of its texture maps and selecting Show Only

o

 

This makes it easier to look for bad data – without data from other scans in the way. 

4.  Use the Select Region (Visible) or the Select Region (All) buttons to select data you wish to delete. Hit the Delete key. 

o

 

Select Region (Visible) will only select triangles that are visible. Select Region (All) will work better for deleting regions 
with small triangles facing in multiple directions.  

Note: Be aware that this will also delete any hidden triangles behind. 

o

 

Turning on ‘back-facing triangles’ by hitting ‘b’ can sometimes help. Hit ‘b’ again to turn them off. 

5.  Select Show All and look at the areas you’ve edited to make sure you haven’t deleted anything you want to keep. If it’s okay, save the model. 

If you’ve deleted too much, just select undo and it will put the edited data back. 

o

 

If it’s your first edit, use Save File As and give the model a new name, e.g. filename_edited.wrl

6.  Do this for each of the scans contributing to the model. Save regularly. Consider saving multiple revisions with numbered names.  

Note: If looking at one scan at a time is still too much, you can select just 1 or 2 texture maps to work on at a time. 
Or, on the other hand, you can choose to look at 2 or more scans at a time. 

Next, delete parts of overlapping scans. 

7.  Find a part of the model where two or more scans overlap. Determine which texture maps contribute to those areas.  

o

 

You may know which scans cover that area. You can also experiment by selecting textures and selecting Show Only to find 
the right pieces. 

8.  Once you’ve identified the pieces, decide which contributions you want to delete. To delete, try the following: 

o

 

Select all the contributing texture maps and select Show Only. This should show you the overlapping area. 

o

 

Use Region Select(All) to select the overlapping region you wish to edit. This will the region from all contributors. 

o

 

Select the texture maps whose contribution you want to delete. Select Show Only. (Now, only the triangles you want to 
delete should be visible.) Hit Delete, then Show All. Even though you selected the region from both contributors, it will only 
delete from what was visible. 

9.  Check the results by selecting all the contributing texture maps and then Show Only.  If you like it, save it. If not, undo and try adjust your 

selections. 

Tactical Tips 

• 

Work on small areas of the model, but look at the whole model regularly to see the results. 

• 

Work on a surface at a time – a wall, a desk top, a door, a part of the floor.  

 

 


background image

DeltaSphere-3000 3D Scene Digitizer 

 

9/23/05 

VIII  Creating Advanced Annotations with SceneVision-3D 

You have a completed, edited model you want to enhance or prepare for a presentation. This guide will discuss a 
few of the more advanced annotations. SceneVision is running with the scene loaded. 

• 

Create a Hotspot. 

o

 

Align the photo (see quick guide to color alignment), but only up to step 3:Apply. Do not do 4:Color. Do save the scene. 

o

 

Select the photo file in the scene tree. Then select Make Hotspot from Photo in the Edit menu. The hotspot will appear in all 
aligned data – models, range data, and photos. Double-click on the outline to make the photo appear. 

o

 

Select the arrow button to drag the endpoints of the outline if you would like to make it smaller. 

• 

Create a High-res Inset. 

o

 

Align the photo (see quick guide to color alignment), but only up to step 3:Apply. Do not do 4:Color. Do save the scene. 

o

 

Select Slice 3D Data. Select the region of the model which you want to replace with the hi-res photo. It can be all or part of 
the photo. 

Note: Sometimes it is easy to identify the area in the photo you wish to insert, but difficult to identify the part of the 
model. To solve this, use the Draw Outline button to outline the area in the photo. Because it is aligned, this outline 
will appear in the model. Use that as a guide for the Slice 3D Data function above. 

o

 

Select Insert Hi-res Photo from the Edit menu. If more than one photo is aligned, choose the photo you wish to use and 
select Okay. This will insert the full resolution photo onto the selected area of the model. Save the model. 

• 

Create a person’s Viewpoint, e.g. a point 65in. (or any height) above a particular spot on the floor. 

o

 

Create a plane for the floor by selecting a region of the floor data in the range or model data, and then Create Plane from 
Region
. Name the plane, e.g. Floor or Bedroom Floor. 

o

 

Make the plane large enough to cover the point where the viewpoint will be located, either by dragging an endpoint or 
selecting the Match Plane to Model Bounds button. 

o

 

Select the plane in the model or in the scene tree. Select the Draw Perpendicular Line button.  

o

 

Holding Ctrl, click on the spot on the plane where the person was located. A window will open. Enter the height of the 
viewpoint, in this case it would be 65. Click Okay. A vertical line will appear at that point.  

Note: You can drag the point at the base of the line if you want to move it to a different spot. 

o

 

Select the Create Viewpoint button. Holding Ctrl, select the top point of the perpendicular line. (If data is in the way, turn 
off the data by selecting the ‘d’ key, then create the viewpoint, then turn the data back on with ‘d’ again.) The view 
‘frustum’ will appear. Rename the viewpoint by right-clicking on it’s name in the scene tree. 

o

 

To lock to the Viewpoint, double-click on it. You can then rotate your view. To set the view frustum to the current 
viewpoint direction, right-click on the viewpoint in the scene tree and select Set Viewpoint Direction

o

 

To return to a standard view, select the ‘t’ key or Move Object in the View menu. 

• 

Create a Viewpoint of a photograph, e.g. the camera’s position when the photo was taken. 

o

 

Align the photo (see quick guide to color alignment), but only up to step 3:Apply. Do not do 4:Color. Do save the scene. 

o

 

Right-click on the photo in the scene tree and select Create Viewpoint from Photo. Rename if desired. See 3. above for 
using the Viewpoint. 

• 

Hyper-Link a file to a point in a scene. 

o

 

Select the Create Landmark Point button and, holding Ctrl, select the point in the model to hyper-link. 

o

 

When the Annotation Properties window opens, name the point with a Label or Description. Select its Show box. 

o

 

Select Browse External to link a file on your computer or network that is not in the scene. Select Browse Internal to link a 
file that is in the scene. Select the file and select Open

o

 

Select OK